[RESOLVED] configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing
Results 1 to 6 of 6

Thread: [RESOLVED] configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Posts
    1

    resolved [RESOLVED] configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing

    I am trying to install php5.2 on Solaris 10.
    While runing the ./configure

    I am getting the folowing error.

    checking for utf8_mime2text signature... new
    checking for U8T_CANONICAL... no
    configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log for additional information.

    Please let me know, If somebody know the solution.

  2. #2
    Senior Member
    Join Date
    May 2003
    Location
    Karlsruhe, Germany
    Posts
    3,610
    Hi,

    that's an error related to the IMAP extension. Possible solutions:

    1. compile without imap support

    2. recompile the imap libraries prior to compiling PHP:

    The manual contains some tips in the user contributed notes.
    Additionally, check out this site. There's a section about IMAP (with php 4.3.x, but it should be the same with php 5.2).

  3. #3
    Junior Member
    Join Date
    Mar 2008
    Posts
    1
    solution: this is because php won't use IMAP without SSL. for some people building IMAP with SSL doesn't work and the compile IMAP with this option SSLTYPE=none

    in order to make IMAP compile u need to install openssl to this folder:
    /usr/local/ssl

    make shure u have the ssl libs accesible too in /usr/local/ssl/lib or /lib

    after that IMAP should compile just fine with SSLTYPE=unix

  4. #4
    Junior Member
    Join Date
    Mar 2008
    Posts
    1
    Hello everyone,

    the problem may have been solved in this case, but I would like to share another solution that may work for some servers:


    Since you have a dedicated (or VPS) server running WHM/cPanel, follow these steps to solve the problem:

    1. Login to your WHM (http://yourserver/whm)

    2. On the left column select Software -> Install a RPM

    3. Find libc-client-devel.i386 in the list. Select it and click Install

    If you are not using cPanel/WHM, just run the following command in your root shell:

    For RedHat based Linux distributions:

    yum install libc-client-devel.i386

    For Debian based Linux distributions:

    apt-get install libc-client-devel.i386

    Now run again configure for your PHP installation. It should configure with no problems.

  5. #5
    Junior Member
    Join Date
    Jul 2008
    Posts
    1

    Worked on Fedora 9

    I had the same problem "U8T_CANONICAL" missing on Fedora 9.. Running yum install libc-client-devel fixed the problem.

  6. #6
    Junior Member
    Join Date
    Feb 2010
    Posts
    1
    Make sure ./configure have using

    --with-openssl --with-imap --with-imap-ssl

    That's means the system have instelled

    openssl
    courier-imap
    courier-authlib
    courier-authlib-base

Thread Information

Users Browsing this Thread

There are currently 4 users browsing this thread. (0 members and 4 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •