PHP problems with WordPress on VPS
Results 1 to 10 of 10

Thread: PHP problems with WordPress on VPS

  1. #1
    Junior Member
    Join Date
    Dec 2012
    Posts
    6

    PHP problems with WordPress on VPS

    I have a problem with my blog, forsejt.dk, I switched from UnoEuro.com, sharedhost, a few months ago because the page had grown from the sharedhost's - the VPS is faster and better, and of course more expensive. It is not the problem. Everything worked on that server.
    The problem is that after I switched to my own VPS, the page can not make wordpress-updates anymore, nor can it show news from wordpress.org(rss feed in backend) or install plugins, themes through the backend. Scheduling post does not work, either.
    The problem must be something with PHP, PHP is not allowed to contact other servers through PHP, or something? I can not find anyone with the same problem, nor anyone who has solved the problem.
    Update menu shows that everything is "up to date" - but when new updates come, it will be shown with a small number next to the menu item to indicate that updates are available, this resets when I try to update.

    2 other pages, bagnefoto.dk and mobilab.dk, are located on the same server, one is brand new, and therefore most likely without a wordpress-error. both has the same PHP error. I haven't changed anything since it worked on the other server.
    My server has CentOS on it, with cpanel running the webserver.
    Apache version 2.2.23, PHP version 5.3.17

  2. #2
    Senior Member
    Join Date
    Mar 2009
    Posts
    809
    Sounds like a server configuration issue. Are there any entries related to this in the PHP error log or the Apache error log? I have never heard of this type of problem before with WordPress. As long as you've migrated your database properly from your old installation then your new site should work just fine.
    Declare variables, not war.

  3. #3
    Junior Member
    Join Date
    Dec 2012
    Posts
    6
    I thought it was something with the php configuration or Apache configuration?

  4. #4
    Senior Member
    Join Date
    Mar 2009
    Posts
    809
    Quote Originally Posted by andersburn View Post
    I thought it was something with the php configuration or Apache configuration?
    Sounds that way.

    Have you tried reinstalling WordPress and just importing your posts, pages, etc.?
    Declare variables, not war.

  5. #5
    Junior Member
    Join Date
    Dec 2012
    Posts
    6
    The site Bagnefoto.dk was installed on same server from new. It has the same problem.

  6. #6
    Junior Member
    Join Date
    Dec 2012
    Posts
    6
    Can anyone point me in the right direktion? A Server-forum? Is this a Apache problem? Cpanel problem?

  7. #7
    Senior Member
    Join Date
    Mar 2009
    Posts
    809
    Quote Originally Posted by Bonesnap View Post
    Are there any entries related to this in the PHP error log or the Apache error log?
    Also, have you tried posting on the WordPress support forums?
    Declare variables, not war.

  8. #8

  9. #9
    Senior Member
    Join Date
    Mar 2009
    Posts
    809
    And the error logs didn't show anything?
    Declare variables, not war.

  10. #10
    Junior Member
    Join Date
    Dec 2012
    Posts
    6
    Nope, not anything

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •