Problem on PHP config with solaris10 - failed for target `install-pear'
Results 1 to 9 of 9

Thread: Problem on PHP config with solaris10 - failed for target `install-pear'

  1. #1
    Junior Member
    Join Date
    Aug 2014
    Posts
    5

    Thumbs down Problem on PHP config with solaris10 - failed for target `install-pear'

    I've been trying to configure PHP in order to work with mysql & sybase database but got a problem

    By using
    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql --enable-mbstring --with-sybase-ct=$SYBASE/$SYBASE_OCS --with-zlib

    • when configuring with-pear option ,i got an error on "make install" with a following command caused the error:

      /opt/php-5.5.14/sapi/cli/php -n -dshort_open_tag=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0 pear/install-pear-nozlib.phar -d "/usr/local/lib/php" -b "/usr/local/bin" -dp a -ds a
      make: Fatal error: Command failed for target `install-pear-installer'

      The following command caused the error:
      if test -f pear/install-pear-nozlib.phar && /opt/php-5.5.14/build/shtool mkdir -p /usr/local/lib/php; then \
      make -s install-pear-installer; \
      else \
      cat /opt/php-5.5.14/pear/install-pear.txt; \
      fi
      make: Fatal error: Command failed for target `install-pear'
    • when configuring without-pear option, the configuration was succeeded but an apache service has gone to maintenance state.After checking log file,i saw this error

      /lib/svc/method/http-apache2: PIDFILE: not found
      httpd: Syntax error on line 149 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: ld.so.1: httpd: fatal: relocation error: file /usr/local/sybase/OCS-15_0/lib/libsybcomn.so: symbol uniconv_HandleGet: referenced symbol not found
      [ Aug 28 22:40:16 Method "start" exited with status 1 ]

      So I check with command ldd and got the result as belowed
      #ldd /usr/local/apache2/modules/libphp5.so
      libsybtcl.so => /usr/local/sybase/OCS-15_0/lib/libsybtcl.so
      libsybintl.so => /usr/local/sybase/OCS-15_0/lib/libsybintl.so
      libsybcomn.so => /usr/local/sybase/OCS-15_0/lib/libsybcomn.so
      libsybct.so => /usr/local/sybase/OCS-15_0/lib/libsybct.so
      libsybcs.so => /usr/local/sybase/OCS-15_0/lib/libsybcs.so
      libresolv.so.2 => /usr/lib/libresolv.so.2
      librt.so.1 => /usr/lib/librt.so.1
      libz.so.1 => /usr/lib/libz.so.1
      libm.so.2 => /usr/lib/libm.so.2
      libnsl.so.1 => /usr/lib/libnsl.so.1
      libsocket.so.1 => /usr/lib/libsocket.so.1
      libxml2.so.2 => /usr/lib/libxml2.so.2
      libc.so.1 => /usr/lib/libc.so.1
      libm.so.1 => /usr/lib/libm.so.1
      libdl.so.1 => /usr/lib/libdl.so.1
      libsybunic.so => /usr/local/sybase/OCS-15_0/lib/libsybunic.so
      libaio.so.1 => /usr/lib/libaio.so.1
      libmd.so.1 => /usr/lib/libmd.so.1
      libmp.so.2 => /usr/lib/libmp.so.2
      libscf.so.1 => /usr/lib/libscf.so.1
      libpthread.so.1 => /usr/lib/libpthread.so.1
      libdoor.so.1 => /usr/lib/libdoor.so.1
      libuutil.so.1 => /usr/lib/libuutil.so.1
      libgen.so.1 => /usr/lib/libgen.so.1
      /platform/SUNW,Sun-Fire-880/lib/libc_psr.so.1
      /platform/SUNW,Sun-Fire-880/lib/libmd_psr.so.1



    Could anyone help me solve this problem?
    Thank you for your kindness in advance.

  2. #2
    Settled 4 red convertible dalecosp's Avatar
    Join Date
    Jul 2002
    Location
    Accelerating Windows at 9.81 m/s....
    Posts
    7,715
    Does this help?

    Quote Originally Posted by Hernst42_@ExpertsExchange
    The problem is that the linker does not find the correct libs to include and thus you get the error. If you locate the correct path and set the option correctly for the linke-flags the build should work. As I don't have sysbase or a solaris sparc currently available all I can advise you is to check for the libraries path during that linking process. Guess it's just a missing option.
    http://www.experts-exchange.com/OS/Unix/Q_22899397.html
    /!!\ mysql_ is deprecated --- don't use it! Tell your hosting company you will switch if they don't upgrade! /!!!\ ereg() is deprecated --- don't use it!

    dalecosp "God doesn't play dice." --- Einstein "Perl is hardly a paragon of beautiful syntax." --- Weedpacket

    Getting Help at All --- Collected Solutions to Common Problems --- Debugging 101 --- Unanswered Posts --- OMBE: Office Machines, Business Equipment

  3. #3
    Junior Member
    Join Date
    Aug 2014
    Posts
    5
    Thank you for your advice. Hope that this help.

  4. #4
    Junior Member
    Join Date
    Aug 2014
    Posts
    5
    it seems that the problem came from -with-mysql option. I don't know what happen when i configure again

    "./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql= --with-mysqli= --with-pdo-mysql= --enable-mbstring --with-sybase-ct=$SYBASE/$SYBASE_OCS --without-pear"

    the configure was error anf gave result like this
    checking for specified location of the MySQL UNIX socket... no
    configure: error: Cannot find MySQL header files under .
    Note that the MySQL client library is not bundled anymore!

    Any suggestion,plese help?
    #whereis mysql
    mysql: /usr/bin/mysql /usr/include/mysql /usr/man/man1/mysql.1
    #find / -name mysql.h
    /usr/sfw/include/mysql/mysql.h
    /usr/include/mysql/mysql.h
    /opt/mysql/mysql/include/mysql.h

  5. #5
    Pedantic Curmudgeon Weedpacket's Avatar
    Join Date
    Aug 2002
    Location
    General Systems Vehicle "Thrilled To Be Here"
    Posts
    21,889
    Unless you'll be using older applications that use the MySQL extension, you shouldn't need it at all (it's been deprecated); the MySQLi and PDO::MySQL extensions are preferred these days.

    If you're not supplying a directory, then you don't need the '='. Conversely, if you say '=', you should follow it with a path.
    THERE IS AS YET INSUFFICIENT DATA FOR A MEANINGFUL ANSWER
    FAQs! FAQs! FAQs! Most forums have them!
    Search - Debugging 101 - Collected Solutions - General Guidelines - Getting help at all

  6. #6
    Junior Member
    Join Date
    Aug 2014
    Posts
    5
    I try config according to your advice,it works when I configure with-mysql ( didn't put '=') && without-pear and no configure with sybase. Thanks to your guideline.

  7. #7
    Junior Member
    Join Date
    Aug 2014
    Posts
    5
    Anyway, do i need to add --with-pdo-mysql option?

  8. #8
    Banned
    Join Date
    Sep 2014
    Posts
    4
    Quote Originally Posted by azsxdckm View Post
    Anyway, do i need to add --with-pdo-mysql option?
    yes, you should add it......

  9. #9
    Senior Member
    Join Date
    Apr 2003
    Location
    Silver Lake
    Posts
    4,884
    Quote Originally Posted by azsxdckm View Post
    Anyway, do i need to add --with-pdo-mysql option?
    It doesn't necessarily have to be pdo-mysql, but you'll need some database extension or you'll be unable to use any database.
    IMPORTANT: STOP using the mysql extension. Use mysqli or pdo instead.
    World War One happened 100 years ago. Visit Old Grey Horror for the agony and irony.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •